Transaction Page Error Affecting Finance Dashboard
Resolved
Apr 30, 2026 at 6:56am UTC
The issue affecting the transaction detail page within the Finance Dashboard has been fully resolved.
Users can now successfully view transaction details without encountering errors after payment completion via Paystack.
Our investigation identified the root cause as a frontend formatting error, which has now been fixed and deployed.
We confirm that:
All transactions processed during this period were successful and remain unaffected.
No financial data was lost or altered.
We appreciate your patience while we worked to resolve this issue. If you experience any further problems, please contact our support team.
Affected services
Created
Apr 29, 2026 at 7:08pm UTC
We are currently investigating an issue affecting the Finance Dashboard where some users may encounter an error when accessing specific transaction details.
This issue occurs after a transaction has been successfully completed via Paystack, but the transaction detail page fails to load properly, displaying a technical error message (ReferenceError: format is not defined).
Please note that:
All payments processed through Paystack remain successful and are not impacted.
The issue is limited to the display of transaction details within the dashboard.
Our engineering team is actively working to identify and resolve the root cause as quickly as possible.
We appreciate your patience and will provide further updates as soon as a fix has been deployed.
Affected services