Back to overview
Degraded

Partial Service Disruption (Post-Domain Migration Issue)

Apr 28, 2026 at 6:54am UTC
Affected services
Menu System
Add-ons System
Drinks Management

Resolved
Apr 28, 2026 at 2:45pm UTC

The earlier issues affecting parts of Foodbase services following the recent domain migration have now been fully resolved.

The disruption was traced to an internal configuration inconsistency affecting how active business data was selected across our systems, which led to mismatched records in business dashboards and financial operations.

We have implemented a consistent business selection mechanism across all services, ensuring accurate data synchronization and stable performance across the platform.

All affected features, including menu management, add-ons, drinks dashboard, and withdrawal processing, are now functioning normally.

We will continue to monitor the system to ensure ongoing stability.

Created
Apr 28, 2026 at 6:54am UTC

We are currently experiencing issues affecting parts of Foodbase services following a recent domain migration from foodbase.vercel.app to foodbase.ng.

Some business features including menu management, add-ons, drinks dashboard, and withdrawal processing may not function correctly at the moment.

We have identified the issue as a configuration mismatch affecting internal API and balance validation systems.

Our team is actively working on restoring full functionality.